BURN IN                                       

Søndag, 27.11.2016
I dag vil jeg påbegynde test af 3D-printeren.
Testen vil omfatte flere ting... 

Lige en opsummering af, hvad jeg mangler:

  1. At føre ledninger mellem ny kabelskinne og RAMPS 1.4
  2. At lave en spoleholder til filament-spolerne
  3. At montere Filament trådføreren fra spole til ekstruder
  4. At beslutte hvilken software, jeg vil benytte, MARLIN eller REPETEIR..
  5. At lave låget til 3D-printeren - finer og plexiglas
  6. Afprøvning og BURN-IN af 3D-printeren

Jeg behøver egentlig kun at udføre punkt 1, for at kunne teste om alt virker, men jeg er noget uvillig til, at vælge den nemme løsning, fordi man kan komme i den situation, at man bliver nød til at færdiggøre noget mere, for at kunne lave en egentlig prøve.

Mandag, 28.11.2016 
I dag er der så blevet kablet det sidste.

Jeg kunne ikke dy mig, og skulle da lige forsøge mig med een motor ad gangen, for at se om det kører, og der kom da også en skuffelse.
X-motoren vil ikke køre som forventet. Den kan ligesom ikke rigtigt finde ud af, hvilken vej den skal, og jeg har endnu ikke fundet problemet.
Y-motoren kører til gengæld helt fint til END-STOP, uden dog at softwaren er endeligt justeret, men det er en mindre ting.

Z-motoren er endnu ikke afprøvet, men det vil nok ske i løbet af i morgen.

Kommandoen "GO HOME" skal virke perfekt, selv om en simulering af 3D-print ser ud til at rykke i begge motorerne, X og Y, efter hensigten.

Tirsdag, 29.11.2016
X-motorens problem er fundet.
Noget så simpelt, som at forbytte 2 ledninger, gav mig problemer. 

Motorenes ledningsfarver er nu standardiseret således, at når de er fremført til klemrækken: RØD, ORANGE = 1B og 1A,  GUL, GRØN = 2A og 2B, passende til RAMPS1.4's rækkefølge, som er 1B, 1A, 2A, 2B.
I samme bundt som X-motoren var kablet, var der en femte ledning, som er brun, og den var, af een eller anden grund, blevet forbyttet med den grønne.  Denne femte brune ledning var SENSE-ledningen til X-ENDSTOP, og altså forbyttet i kampens hede med een af motor-ledningerne. Hele miseren kommer altså af, at fladkablet har ialt 25 ledninger, og i stedet for at fjerne de 5 ledbninger, blev de tilkoblet X-drevet, som alligevel skal kables ad samme kanal som alle ledningerne fra ekstruderen. Hmmm. kan det gå galt, så går det galt.

Nu er alle ENDSTOP-ledninger ajourført med farverne RØD, BRUN og Orange, så der kan der hellerikke mere tages fejl.

Onsdag 30.11.2016
Nu er jeg rykket fra værkstedet og ind i mit radiorum, som ligge inde i selve huset, og jeg er ikke mere afhænghiet af en varmeovn - det var dejligt!!
Her er konstant varme hele tiden i vores tidligere soveværelse.

Ledningerne, der skal forbindes til RAMPS1.4, er nu standardiseret, og ser således ud:

Jeg har nu forbundet ledninger til X og Y, og her laver jeg en simuleret 3D-printning, med blot disse 2 motorer, og det kører..

Opvarmningen af NOSLE virker perfekt, og temperaturen passer meget fint. Den skal begynde og printe ved omkring 200 grader.
Simuleret kørsel i 15 minutter og 13 sekunder.

   KLIK på billedet...

I dag er HEAD-BED monteret og afprøvet. Den varmer fint op (sat til 80 grader ) med 2 graders hysterese, så relæet slår fint fra ved 82 grader, men det ses, at temperaturen fortsætter til ca. 84 grader før den stopper og vender. Når den kommer under 80 grader starter relæet den igen og den varmer igen op til 82 grader, slår fra, fortsætter til ca. 84 grader, hvorefter den falder igen, så igen en succes....

Torsdag, 01. 12.2016

I dag er LED-lyskæderne monteret:

 Om det giver lys i kassen ???

  Johh... Det tør nok siges...

Søndag, 4.11.2016
Jeg har nu arbejdet på printeren i et par dage, uden at opdatere denne side, og det skyldes det faktum, at der er et problem med printbordet.

Jeg kan fint få det til at køre op og ned, men jeg har opdaget, at det kan blive meget svært, at justere level. og det er uanset om det er bliver gjort med en skruetrækker, eller hvis det skal gøres automatisk. Bordet er simpelthen ikke stabilt nok.

Denne video viser problemet:

Nu går jeg lige i tænkeboksen i et par dage for at udtænke en ordentlig og stabil løsning... hvis den findes...?

Hvis jeg ikke finder en løsning på dette, så slutter projektet meget snart... hm....

Noget senere....
Det bliver noget i denne retning, tror jeg:

  2 stk. af dem her...

Nu må jeg så se at få fat i min ven igen....

Idéen er så, at placere, den noget længere end normale, møtrik over hullet, og give den en svejsning i kanten, så præcist som det er mulig, i vandret plan, uden at komme til at beskadige gevindet i møtrikken. 
Pladen med møtrikken placeres så under finerpladen, og spændes fast med de 4 skruer, og der bliver, med denne løsning, ingen plade på oversiden af finerpladen.

Denne løsning vil måske forøge vægten lidt, men hvor meget det kommer til at betyde, ved jeg endnu ikke - formodentlig intet...

Nu skal de laves og monteres, så tager jeg den derfra....

Torsdag, 08.12.16

Og så har jeg opdaget... 
Regulatoren til 5 volt på Atmega2560'eren, AMS1117-5 i SOT-223, virker tilsyneladende ikke. 

Det kan så være, at det er en af stepper driverne der på et tidspunkt har jaget den til de evige regulator-marker, der sker i hvert fald ingen regulering, men gerne et spændingsfald. 10 volt IND giver mere end 6 volt UD, og det er jo ikke meningen. Men tilsyneladende er der ikke sket noget med resten af printet... Programmet kører fint, og reagerer som det skal på både UPLOAD og KOMMANDOER fra SERIAL INPUT... 

For en sikkerheds skyld har jeg bestilt et nyt print fra Kina... Hvornår mon det kommer ? Det ender nok med bare at blive reserveprint...
Nu er jeg på jagt efter en ny regulator - 10 stk. til 1 US dollar på EBAY fra Kina, men gider jeg vente på det ?? hmm.... All den ventetid er jo næsten uudholdelig...

Desuden har jeg bestilt 3 ny MØTRIKKER til TRAPEZ-spindlerne - en ekstra til at ødelægge, hvis det skulle være nødvendig, nok et panikkøb - og min ven står klar til at vi skal have lavet nogle mere stabile elevator-førere. Så snart de er klar kommer der billeder af dem herunder.

Min ven var hjemme i aften, såh....

Der var ikke noget der blev ødelagt, så det blev til disse billeder i dag. 
Møtrikkerne er blevet tilpasset med en krave på 2 m.m., drejet ned til 16 m.m. i diameter, og derefter monteret på pladen i et tilsvarende 16 m.m. hul, og slagloddet på 2 m.m. jernplade, og det hele kører i olie. 

   

 

OPDATERING: Har nu taget konsekvensen og bestilt en NY Arduino MEGA 2560 og 5 nye stepperdrivere. De kommer formodentlig i morgen fra en lokal leverandør.

Jeg kan ikke vente til efter nytår med at få leveret fra KINA/HONGKONG, så denne beslutning bliver så lidt mere omkostningsbesværlig og panikagtig, men det er der jo så ikke noget at gøre ved. Jeg vil meget gerne se denne 3D-printer i funktion inden jul, og det kan måske også lykkes, for jeg er jo stort set færdig med det egentlige byggeri, og mangler jo bare lige at få disse spindler til at køre fornuftigt, uden for meget slinger i valsen.

Fredag, 09.11.2016
Noget er da lykkedes...
Men spindlerne driller stadig. Stabiliteten er øget ganske væsentlig, og det er en god ting, men der er stadig nogen der af og til holder elevator motorene, så de ikke trækker.

Arduino Mega er ankommet sammen med 4 ny stepper drivere - monteret og afprøvet med et testprogram, jeg fandt på denne side: http://reprap.org/wiki/RAMPS_1.4, næsten helt nede i bunden af siden. Programmet tester alle motorer samtidig og på skift.

Derefter forsøgte jeg mig med et testprint, og ekstruderen virker nu også, men desværre var jeg ikke hurtig nok til at få taget et billede, men der kom da noget ud af ekstruderen:

Der er flere interessante oplysninger på den side, bl. a. ser jeg, at der er kommet et nyt RAMPS1.4.2, så det skal lige nærlæses.

Mandag, 12.12.2016
Jeg har stort set ligget stille i weekenden, og ikke lavet noget på printeren andet end tænkt tanker.

Jeg har et problem med Z-elevatoren. den låser i de 4 hjørnestyringer, og det skyldes formodentlig stadig disse trapez-møtrikker. Lige nu har jeg forespurgt leverandøren, om han havde en løsning, men han er blot videreforhandler af disse trapez-gevindstænger med møtrikker, og laver tilsyneladende ikke noget selv. 

Nu har jeg bidt - igen - i det sure æble, og har en forespørgsel hos et professionel Maskinværksted, og her håber jeg virkeligt, at der er hjælp at hente, men nu må vi se. 
Man kan jo næsten sige, at jeg er kommet til et punkt "With NO RETURN" - nu skal den altså snart virke, ellers er pengene jo spildt.

Mandag, 19.12.2016
Jeg har ikke haft nyheder hele ugen, for de vertikale trapez-spindler spøger stadig.
Eksperimenter ugen igennem har dog nu givet et vist resultat, og fredag aften, fik jeg dem til at køre helt op og helt ned. Det var dog kun fordi jeg havde løsnet alt hvad der kunne løsnes,, og det er jo uholdbart.

Jeg havde en samtale
onsdag  med en anden ven, som hele livet har arbejdet med CNC-maskiner af alle mulige slags, og som jeg ved, har et meget fint finmekanisk værksted . 
Det endte med, at jeg inviterede ham til at komme og se på problemet, og han kom fredag eftermiddag.

Efter få minutters betragtning af mit problem, sagde han, at det der får du aldrig til at køre ordentlig. Trapez-spindlerne må på ingen måde kaste sig, selv om det kun er en lille smule.
De metalbeslag der er lavet og slagloddet på møtrikkerne, er ikke helt lige, men hvis du afmonterer det hele, altså spindler og beslag, kan du komme over til mig mandag aften, så skal jeg vise dig, hvad der er galt. 

Testen hjemme hos ham viste da også, at afdrejningen er "OFF-CENTER" med 0,6 m.m. hvilket betyder, at mine nye metal-beslag kommer til at slå sig, hvilket får printbordet til at låse i de fire lodrette styr i hjørnerne af printbordet.

Det ene nye metalbeslag har også en ubetydelig vinkel-skævhed, som kan rettes med en 0,3 m.m. metalskive i den ene side, hvorimod det andet beslag stort set er vinkelret.

Han tilbød derefter, at dreje spindler af, så de kommer til at køre som de skal. Dette bliver dog først efter nytår, så nu venter jeg igen...

KLIK på billedet for at se video.

Endvidere foreslog han, at jeg skulle have nogle længere styr i hjørnerne. Der sidder et enkelt glideleje i hvert hjørne, og jeg skal have fat i fire stykker mere, og montere et mere i hvert hjørne i forlængelse med de der sidder i forvejen. Det vil give væsentlig bedre styr lodret, så det skal prøves.

Disse styr er nu monteret, og det har virkeligt hjulpet på stabiliteten. 

Se selv: https://www.youtube.com/watch?v=g3lAlC4ih-E&feature=youtu.be

Fredag, 23.12.2016
I dag kom der spændingsregulatorer fra Kina...
En hurtig montering og test af den tidligere brugte Arduino MEGA viser, at den ikke fejler noget ellers. Testprogrammet fra WIKI - tidligere nævnt - virker perfekt på alle 3 motorer, og d.v.s. at jeg nu har en reserve-Arduino med 4 drivere til, som virker.

Næste opdatering efter nytår.

GodtNytår...

Søndag, 01.01.2017
De nydrejede spindler er nu monteret, men mine problemer er endnu ikke løst sig.
Jeg har lavet en video, som viser problemet, men forklaringen er, at det slup, der er konstateret i trapez-møtrikkerne, betyder, at den mindste belastning på dem, bremser kørsel op og ned.

Det holder ikke rigtigt...lige en video mere...

Fredag, 06.01.2016
Ugen er gået med kontrol og justering af X- og Y-aksen, kontrol af END-STOP m.v. og jeg skulle mene, at det nu kører for X-Y akserne.

Endvidere er jeg gået lidt i tænkeboksen m.h.t. TRAPEZ-spindlerne.  Den ene (venstre) kører fint, og uden slør, men den højre er der nogle hundrede dele slør i, hvilket giver sig til kende ved, at hvis jeg spænder printbordet fast i venstre side, hænger printbordet fast i gevindet.

Jeg har besluttet, at forsøge med et nyt TRAPEZ-gevind til højre side, og bestilt en enkelt fra leverandøren i Jylland. 

Ved gennemgang af hans regnskab, opdagede han, at jeg faktisk havde betalt for 3 spindler i første omgang, så han ville lige sende min en spindel mere, uden beregning, ... og det er jo ikke så galt...  
Den kunne dog ikke komme af sted før MANDAG den 9. januar, så jeg venter lige igen.

Dog har mine eksperimenter i ugens løb haft en negativ indflydelse på CPU-systemet, som jeg ikke lige kan identificere.
Efter, at jeg havde LOADED et kontrol-program fra nettet, der skulle kontrollere retning og bevægelse af X-Y akserne, er der sket noget helt uforudset og uforståeligt. 
Hvis jeg med programmet pronterface.exe f. eks. ønsker at køre X-aksen fra højre til venstre og retur, flytter den Y-aksen også således, at banen bliver skrå, 90 grader i forhold til den retning jeg ønsker. Hvis der ikke er monteret en kontroller til den ene akse, f. eks Y-aksen, kører X-aksen som den skal, og visa versa, men hvis der er kontroller til både X- og Y-aksen køres der i 90 grader...??? Underligt... OG... det er konstateret, at det ikke har noget med spændingen at gøre. Det var et forslag fra en ven, som mente, at jeg skulle checke forholdet med og uden tilslutning af USB til PC-en, og min 3D-printer forsyning er designet til 30  Amp.

Ikke nogen dokumentation uden en video:

Hvorledes det kan være, har jeg ingen forklaring på, andet end at det må måske være stepper-kontrollerne der et sket noget med. 
Min erfaring siger mig, at disse POLOLU A4988 faktisk er ret følsomme.
For en sikkerheds skyld, har neg bestilt 5 nye kontrollere i Kina, med Estimated delivery Jan 24, 2017 - Mar 06, 2017, så jeg venter lige igen. 

Det kan godt betale sig med ventetiden for nuværende, da 5 drivere i Kina koster 35 kroner, men købt her hjemme er prisen over 200 kr incl. porto, og lige nu er der jo god tid, for jeg skal have den nye spindel hjem. Så skal den drejes til og monteres, checkes i alle ender og kanter, så tiden skal nok gå,
Så kan det da godt være, at jeg alligevel bliver nød til at køre en tur til Helsingør, og hente 2 kontrollere, når der kommer lidt mere varme i luften, end der er i dag. Lige omkring mig, er temperaturen i haven minus 9 grader.

Tirsdag, 21. feb. 2017
Der måtte ske noget...
Nu tror jeg, at jeg får styr på TRAPEZ-spindlerne.

Jeg har investeret i nogle 12/3 TRAPEZ-gevind-møtrikker, i BRONCE - ja, faktisk nogle ret "heavy" nogen, og CNC-HOBBY var leveringsdygtige, men prisen var derefter:  299 kr. pr stk. hvortil der kom fragt.   Bestilt i fredags og leveret i dag.

De er 35 m.m. høje, hvilket er dobbelt så meget gevind, som på de tidligere brugte, og så har de en diameter på 48,5 m.m, så det er jo en god "trædeplade" for selve elevatoren. De 6 huller i kraven er M5 gevind.

Når de drejes rundt på gevindstangen, virker de meget mere stabile og sikre, og det bedste er, at der så og sige ingen slør er mere.

Nu skal de monteres, og smøres i vaseline, så må vi se hvordan de spiller.

Tirsdage den 19.sept. 2017

Hvor har jeg spild mange timer på disse spindler...
En dag i september ser jeg pludselig en annonce på E-BAY med disse:

Hele settet sat til 300 D.kr. hvor der kan vælges mellem forskellige længder bl. a. den jeg bruger 500 mm.

Antibacklash Ball Screw SFU1605 L250-L750mm + BK/BF12 + 2pcs 6.35*10mm Couplers

Annoncen kan findes her:

http://www.ebay.com/itm/Antibacklash-Ball-Screw-SFU1605-L250-L750mm-BK-BF12-2pcs-6-35-10mm-Couplers-/382230889469?var=&hash=item979647a4a0

Hvor kan de mon have fået idéen fra til de 2 sorte holdere yderst til højre i billedet, eller i hver ende af den ene spindel??

Der er tilsyneladende flere annoncer i samme stil, f. eks. er her en billigere model, til 60 kr. stk.:

http://www.ebay.com/itm/T8-500mm-Lead-Screw-Rod-w-Nut-Shaft-Coupling-Mounting-Support-for-3D-Printer/322495047788?_trkparms=aid%3D222007%26algo%3DSIM.MBE%26ao%3D2%26asc%3D41376%26meid%3D4cbd653875fc45d49a924fd0ffa637a6%26pid%3D100005%26rk%3D2%26rkt%3D6%26sd%3D381860061254&_trksid=p2047675.c100005.m1851

Det kan virkelig godt betale sig at kigge E-BAY godt igennem...

Prøv selv at søge på:   Lead Screw Rod

 

Torsdag, den 23. februar 2017

De nye møtrikker er nu på plads. 
Se dagens video her:

                 https://www.youtube.com/watch?v=nKzp1RxuoRM&feature=youtu.be

Nu skal jeg igen kigge på softwaren.

Fredag, den 24. februar 2017

Så er jeg i gang med at justere tingene på plads, og om ikke det er lykkedes at få elevatoren til at køre... og tilsyneladende helt perfekt, og så har de endnu ikke fået noget vaseline at dreje rund i... he he

Se dagens video her: 

                 https://www.youtube.com/watch?v=3rbb6itWGmY&feature=youtu.be

Næste opgave bliver, at få softwaren til at reagere på ENDSTOP på alle tre akser, men det skal nok også lykkes... Nu må vi se...

Lørdag, den 25.- Februar 2017

Nu skal tingene jo ikke være alt for nemt at få til at fungere...

Den første BRÆNDPRØVE, efter at have fundet den ledning, der var faldet af i kampens hede, så EXTRUDEREN ikke virkede...

Ja.... Det var så første prøve... Ikke en udpræget succes, med dog... der kom da noget ud af extruderen.

mere senere...